Some PDFs Unavailable
Incident Report for Liaison International
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 01:00 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 31, 2022 - 20:06 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 31, 2022 - 19:43 EDT
Investigating
We are aware that some users may be experiencing issues downloading PDFs.

Our technical support team is currently looking into the issue and will provide an update when we have more information. Thank you for your patience and we apologize for any inconvenience this may cause.
Posted May 31, 2022 - 17:47 EDT
This incident affected: Advisors (Universal Advisor Portal), WebAdMIT (WebAdMIT, WebAdMIT PDFs), and CAS (Applicant Portal, Applicant Portal PDFs, Evaluator Portal (LORs)).