Some PDFs Unavailable
Incident Report for Liaison International
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 20:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2022 - 19:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 12, 2022 - 13:40 EDT
Investigating
We are aware that some users may be experiencing issues downloading Full Application PDFs from WebAdMIT. Please re-try if you are having difficulty as that may solve the issue.

Our technical support team is currently looking into the issue and will provide an update when we have more information.

Thank you for your patience and we apologize for any inconvenience this may cause.
Posted Sep 12, 2022 - 10:36 EDT
This incident affected: WebAdMIT (WebAdMIT PDFs).